
Loading

Loading
We use strictly necessary cookies to run this site, and analytics cookies to understand how it's used. See our Privacy Policy for details.
A GitHub-reviewed security advisory, not necessarily under active exploitation the way our CISA KEV advisories are, but a real, disclosed vulnerability in an open-source dependency.
Affected packages
Vulnerable: < 2.4.37
Patched in 2.4.37
Vulnerable: >= 3.0.0, < 3.1.8
Patched in 3.1.8
Details
What kind of vulnerability is it? Who is impacted?
It has two related instances that share the same root cause: a user-controlled model field is assigned verbatim to a form field's help_text, which is rendered with Django's |safe filter (render_field.html), bypassing auto-escaping.
In both cases the script executes in the browser of any user who opens an affected create or edit form, including administrators and superusers. Because the payload runs in the victim's authenticated session, it can lead to actions performed as the victim, session/token theft, and further privilege escalation. Exploitation requires the victim to open an affected form.
A user who holds the add/change permission for Relationships (extras.add_relationship / extras.change_relationship) can set a Relationship's description to an HTML/JavaScript payload. That description is used as the help text of the relationship's form field and is rendered on the create/edit page of every object type the relationship applies to.
A user who holds the add/change permission for Module Families (dcim.add_modulefamily / dcim.change_modulefamily) can put a payload in a Module Family name, which is interpolated into the module_family field's help text on the Module "Install module" form for any module bay assigned to that family.
Has the problem been patched? What versions should users upgrade to?
Fixes are available in Nautobot v2.4.37+ & v3.1.8+
Note: The underlying weakness exists in earlier EOL versions of Nautobot (v1.x). Users on those older EOL versions are highly encouraged to upgrade to a supported version.
Is there a way for users to fix or remediate the vulnerability without upgrading?
There is no configuration-only fix. To remediate without upgrading:
extras.add_relationship / extras.change_relationship and dcim.add_modulefamily / dcim.change_modulefamily permissions to fully trusted administrators only.<script> content and remove any payloads.Note that limiting who can open create/edit forms does not fully mitigate the issue, since the payload targets any user (including admins) who opens an affected form.
Credit for this discovery goes to Habibullo Izzatilloyev.
EPSS, exploit probability
Low0.30%
estimated chance of real-world exploitation in the next 30 days, higher than 22.6% of every CVE FIRST.org scores
Refreshed 11/7/2026, via FIRST.org's EPSS model, not CVSS, this measures likelihood of exploitation, not how severe it would be.
Talk to us about this
Find out whether this dependency (or others like it) is actually reachable in your codebase.
Get help patching, or building dependency-scanning into your pipeline going forward.
A secure code review or supply chain review finds this before an advisory does.