
Loading

Loading
We use strictly necessary cookies to run this site, and analytics cookies to understand how it's used. See our Privacy Policy for details.
A GitHub-reviewed security advisory, not necessarily under active exploitation the way our CISA KEV advisories are, but a real, disclosed vulnerability in an open-source dependency.
Affected packages
Vulnerable: >= 1.12.0, < 1.21.2
Patched in 1.21.2
Vulnerable: >= 1.22.0, < 1.22.2
Patched in 1.22.2
Vulnerable: >= 1.23.0, < 1.23.1
Patched in 1.23.1
Details
The KubeEdge NodeUpgradeJob handler constructed the keadm upgrade edge command by concatenating the user-controlled spec.version and spec.image fields into a shell command.
An authenticated user with permission to create or update NodeUpgradeJob resources through the v1alpha2 API could include shell metacharacters in either field. When the upgrade job was processed, the injected command could be executed on the targeted edge node with the privileges available to the upgrade process.
Successful exploitation could result in arbitrary command execution and compromise the confidentiality, integrity, and availability of the affected edge node.
The fix removes shell-based command construction and invokes keadm using a structured argument list through exec.Command.
The version and image values are passed as separate literal arguments and are no longer interpreted by a command shell.
The fixed versions:
Until a patched version is available:
NodeUpgradeJob resources to trusted administrators;spec.version or spec.image fields;KubeEdge thanks Sang-Hoon Choi (KoreaSecurity, Sejong University) for responsibly reporting this issue and for coordinating with the KubeEdge maintainers through the security disclosure process.
EPSS, exploit probability
Low0.48%
estimated chance of real-world exploitation in the next 30 days, higher than 42.0% of every CVE FIRST.org scores
Refreshed 11/7/2026, via FIRST.org's EPSS model, not CVSS, this measures likelihood of exploitation, not how severe it would be.
Talk to us about this
Find out whether this dependency (or others like it) is actually reachable in your codebase.
Get help patching, or building dependency-scanning into your pipeline going forward.
A secure code review or supply chain review finds this before an advisory does.