
Loading

Loading
We use strictly necessary cookies to run this site, and analytics cookies to understand how it's used. See our Privacy Policy for details.
A GitHub-reviewed security advisory, not necessarily under active exploitation the way our CISA KEV advisories are, but a real, disclosed vulnerability in an open-source dependency.
Affected packages
Vulnerable: >= 1.4.1, <= 1.6.7
Patched in 1.6.8
Details
fromJSON and fromCrossJSON did not check that an array node's element list is an array. A small crafted payload could set the length the decoder used. That length controlled how much memory was allocated and how many times the decoder looped, and it did not depend on the size of the payload.
A service that passes untrusted input to fromJSON or fromCrossJSON can be made unavailable by an unauthenticated request.
This affects any framework that decodes request bodies with these functions before its own validation runs.
This issue is a bypass of the fix for GHSA-66fc-rw6m-c2q6 in 1.4.1.
Fixed in [email protected]. The deserializer now rejects any node whose element list is not an array, and throws SerovalMalformedNodeError.
None. Upgrade to 1.6.8.
EPSS, exploit probability
Low0.36%
estimated chance of real-world exploitation in the next 30 days, higher than 30.2% of every CVE FIRST.org scores
Refreshed 10/28/2026, via FIRST.org's EPSS model, not CVSS, this measures likelihood of exploitation, not how severe it would be.
Talk to us about this
Find out whether this dependency (or others like it) is actually reachable in your codebase.
Get help patching, or building dependency-scanning into your pipeline going forward.
A secure code review or supply chain review finds this before an advisory does.